certonLOG(+)
Benutzerhandbuch
×

certonLOG/certonLOG+

Benutzerhandbuch
(c) Benninger Automation, 2019


Rechtliches

Rechlicher Hinweis
Die in dieser Hilfe beschriebene Software wird unter einer Lizenzvereinbarung zur Verfügung gestellt und darf nicht kopiert werden.

Alle Rechte, insbesondere das Recht der Vervielfältigung und Verbreitung sowie der Übersetzung sind vorbehalten.
Kein Teil der Dokumentation/Betriebsanleitung darf in irgendeiner Form (Druck, Fotokopie, Mikrofilm oder anderes Verfahren) ohne schriftliche
Genehmigung der Firma Benninger Automation GmbH reproduziert oder unter Verwendung elektronischer Systeme gespeichert, verarbeitet
oder verbreitet werden. Zuwiderhandlungen verpflichten zu Schadensersatz.
und
sind geschützte Marken der Firma Benninger Automation GmbH.
Alle Produkt- und Firmennamen sind eingetragene Marken ihrer jeweiligen Eigentümer.
Ihre Verwendung impliziert keinerlei Verbindung mit oder Verkaufsförderung durch diese Eigentümer.
Freigabe/Lektorat
Erstellung | Datum | Version | Lektorat | Freigabe
C.Knapp | 27.6.2019 | 2.0 | G.Neu | 17.7.19
Copyright © 2019 Benninger Automation GmbH
Benninger Automation GmbH
Schopfheimer Str. 89 | D-79669 Zell im Wiesenthal
Tel. | 49(0) 07625 1310
Fax. | 49(0) 07625 1310-1288
E-Mail: automation@benningergroup.com


1 Einleitung

Danke, das Sie sich für certon entschieden haben! certon ist eine sichere Lösung für Datenerfassung und Protokollierung bei Forderung
durchgehender Datenprotokollierung. certon arbeitet mit dem OPC-UA-Protokoll, der Industrie 4.0-Standard-Schnittstelle.
certon bietet Konfigurieren statt Programmieren, umfassendes Datenmanagement, Signierung der Daten während der Aufzeichnung
(certonLOG+), und die Möglichkeit flexibler Visualisierung. Der AUDIT-Trail zeigt eine chronologische Prozessbeschreibung -
nachträgliche Datenmanipulationen werden dabei offensichtlich.
certon exportiert in ihr Wunschformat (xml/pdf/excel), und ihre Produktion arbeitet nach GMP-Richtlinien.


1.1 Übersicht Dokumentationen

Für certon existiert eine Onlinehilfe, die die beiden Module certonVIEW und certonLOG(+) vollständig dokumentiert. Auch die Konfiguration der
CSV (früher eine separate Anleitung) ist hier integriert.

Für den Einstieg existieren neben dieser Dokumentation verschiedene Tutorials, darunter ein Tutorial für die CSV, für Konfiguration und
Benutzung von certonLOG(+) und zum Installieren von certonLOG(+).
Für die Installation und die Benutzung von certonVIEW existiert je ein separates Tutorial. Für den Softing OPC UA Client (von uns empfohlen)
gibt es ein weiteres Tutorial. Die Tutoriale liegen als Filme auf dem Youtube-Kanal der Firma Benninger vor.


1.2 Funktionen certonLOG(+)

Mit dem Modul certonLOG(+) werden bei certon die von einem OPC-UA-Server bereitgestellte Prozessdaten in Logdateien
aufgenommen. certonLOG bzw. certonLOG+ beinhaltet folgende Funktionen:
§ Konfigurierbare Schnittstelle: Bereitstellung einer konfigurierbaren Schnittstelle zum beliebigen Auslesen von Maschinendaten.
Konfiguriert wird flexibel über ein textbasiertes Tabellenformat.
Die Schnittstelle ermöglicht ebenfalls die Integration von sprachabhängigen Texten.
§ Prozessgesteuerte Datenabfrage: Prozessgesteuerte, automatische Abfrage der Daten nach konfiguriertem Abfrageverhalten.
§ Datenablage: Daten werden in einer separaten SQL-Datenbankdatei pro Loggingauftrag gespeichert.
§ Userinterface: Userinterface zur Anzeige des aktuellen Auftrags, des Loggingstatus und weiterer Details.
§ Konfigurationsmenü zur Einstellung: Konfigurationsmenü zur Einstellung der Datenquelle bzw. des Ablageortes, notwendiger
Zertifikate und dem Lizenzierungsbereich.
§ Signierung der aufzuzeichnenden Daten (certonLOG+): Zur Qualitätssicherung können einzelne Daten signiert werden, um
eine nachträgliche Änderung erkennbar zu machen.


1.3 Zeichen und Formatierungen

In dieser Anleitung wird mit folgenden Symbolen auf Probleme oder Belange hingewiesen:

Das rote Ausrufezeichen warnt vor potentiellen Belangen und wichtigen Risiken.

Das blaue Ausrufezeichen warnt vor möglichen Schwierigkeiten in der aktuellen Situation.

Das blaue Fragezeichen verweist auf Hilfestellungen und Rat bei typischen Fragen

.

Darüber hinaus werden folgende Darstellungskonventionen verwendet:
  • •
    Sowohl certonLOG als auch certonLOG+ werden in dieser Anleitung zusammenfassend als certonLOG(+) bezeichnet.
    Nur wenn die Unterschiede beider Varianten herausgestellt werden, wird mit certonLOG+ oder certonLOG auf die
    jeweilige Versionen verwiesen.
  • •
    Texte, die in certon-Menüs erschienen, wie z.B. "Sortieren nach", werden kursiv dargestellt.
  • •
    Verweise auf andere Kapitel sind blau dargestellt und unterstrichen. Ein Klick auf den Verweis öffnet das entsprechende Kapitel.
  • •
    Wichtige Begriffe werden fett gedruckt.
  • •
    Verweise auf die Tasten ihrer Computertastatur werden in eckigen Klammern dargestellt (zum Beispiel "Drücken Sie [Shift] + [Enter]").
  • •
    Bei Handlungsschritten wird numerisch vorgegangen.
  • •
    Ergebnisse von Handlungen werden durch vorangestellte Pfeile (→) dargestellt.


1.4 Softwarestand

Bei Versionen unter 2.0 lesen und verwenden Sie bitte das entsprechende Handbuch!

Die aktuelle Softwareversion ist 2.2.705.25. Folgende Änderungen haben sich ergeben:
Version | Änderungen
2.2.705.25 | Scrollbalken im Einstellungsfenster erlauben Zugriff auf alle Parameter bei geringen Auflösungen.
 | Verbesserte Fehlerbehandlung bei Auswahl von Hilfe- und Konfigurationsdatei.
 | Verbesserte Einlesen von csv-Dateien. Anpassen der Sprachdateien für certonLOG(+).
 | Verbesserung der Eingabe von Schlüsselwörter in der GroupConfig (Spalte Behaviour): Korrrekte Erkennung nachfolgender Schlüsselwörter. Fehlermeldung bei falschen oder falsch geschriebenen Schlüsselwörtern. Erkennung falsch geschriebener optionaler Argumente (SamplingInterval oder Deadband) im ON_CHANGE-Schlüsselwort. Ausgabe einer Fehlermeldung bei zu kleinen Intervallen beim ON_INTERVAL-Schlüsselwort.
 | Verändertes Loggingverhalten: Als Altwerte werden aktuelle Variablenwerte für alle Variablen vom OPC-Server abgerufen. Das Verwenden zuletzt geloggter Altwerte ist weiterhin möglich.
 | Einbindung der überarbeiteten Handbücher im chm-Format in die Installation von certonLOG(+).
2.2.674 | Das Programm lässt sich jetzt auch bei Fehlen einer der vier benötigten Hardware-Kennziffern initialisieren.
 | OPC-Server mit der Verschlüsslungsart Basic256Sha256 werden jetzt von certonLOG(+) unterstützt.
 | Öffnen von zwei certonLOG(+)-Instanzen nicht mehr möglich.
 | Vereinheitlichte Texte in certonLOG(+).
 | Anpassung der Texte in den Installern von certonLOG(+).
2.2.658 | Benutzerunabhängige Einstellungen mit Datei "settings.json".
2.2.657 | Nur deutsche Texte in der Zertifikatsverwaltung.
 | Serversuche startet auch mit Enter.
2.1.579 | Konfigurierbares Arbeitsverzeichnis.
 | certonLOG(+) kann ohne Adminrechte gestartet werden.
2.0.565 | certonLOG(+) Merkmal: Variable (Bool) erfassen auf Flanke (positiv/negativ).
 | Logging erst möglich, wenn Änderung größer als Werte der Totzone. Abtastrate dabei einstellbar.
2.0.563 | Validierung großer clf-Files verbessert.
2.0.580 | Fehlermeldung, wenn Daten nicht mehr abbrufbar sind.
 | Nach Eingabe Serversuche mit Enter startbar.
2.0 | Diverse Änderungen.


1.5 Systemvoraussetzungen

Für certonLOG(+) benötigen Sie einen PC mit Dualcore und einer neueren Windows-Version, und einen OPC-UA-Server.
Für den PC empfehlen wir 4 GB RAM für flüssiges Arbeiten.
Für alle Maschinen und Anlagen, die über keinen PC verfügen, liefert Benninger mit certonBOX einen kompakten Hutschienen-PC, auf
dem alle notwendigen Komponenten bereits vorinstalliert sind.


1.5.1 Minimale Systemvoraussetzungen

  • •
    Prozessor: Dual Core (empfohlen Intel)
  • •
    Arbeitsspeicher: 2 Gigabyte RAM
  • •
    Betriebssystem: Windows 7 (32/64Bit), Windows 8 (32/64Bit), Windows 10 (32/64Bit)
  • •
    Dateisystem: NTFS
  • •
    Speicherplatz (ohne Datenablage) min.: 100 MB
  • •
    Ethernet Netzwerkschnittstelle
  • •
    Beliebiger OPC-UA-Server
  • •
    .NET Framework 4.52


1.5.2 Empfohlene Systemvoraussetzungen

  • •
    Prozessor: Quad Core (empfohlen Intel)
  • •
    Arbeitsspeicher: 4 Gigabyte RAM
  • •
    Betriebssystem: Windows 7 (32/64Bit), Windows 8 (32/64Bit), Windows 10 (32/64Bit)
  • •
    Dateisystem: NTFS
  • •
    Speicherplatz (ohne Datenablage): 200 MB
  • •
    Ethernet Netzwerkschnittstelle
  • •
    Beliebiger OPC-UA-Server
  • •
    .NET Framework 4.52


2 Schnellstart

Das Fenster "Einstellungsverwaltung" erreichen Sie aus der Anwendung mit der Schaltfläche "Einstellungen" [image]!

1.Installieren Sie certonLOG(+) vom Installer (USB) und starten Sie das Programm.

  • 1.
    Lizenzieren Sie certonLOG(+), indem Sie im Fenster Einstellungsverwaltung den Produktschlüssel (4) kopieren,
    exportieren und an Benninger Automation senden (3) und die Lizenzdatei einlesen und aktivieren (5).

    Dateipfade

    Nach oben

    Server wählen

    Nach oben

    Produktschlüssel exportieren

    Nach oben

    Produktschlüssel

    Nach oben

    Lizenz aktivieren

    Nach oben
  • 2.
    Legen Sie den Speicherort für Konfigurationsdatei, Speicherordner und Arbeitsverzeichnis fest (Position 1 oben).
  • 3.
    Laden Sie eine der mitgelieferten Konfigurationsdateien. Für ihre Arbeit müssen Sie sie später anpassen.
  • 4.
    Betätigen Sie die Schaltfläche "Server wählen" (Position 2 oben).
    5. Geben Sie die IP-Adresse des Servers in das Eingabefeld "URL" (1) ein, und stellen Sie die
Verschlüsslungsart (Encoding) ein (2).

6. Übernehmen Sie den Server in die Auflistung mit der Schaltfläche "Hinzufügen" (3).
7. Starten Sie die Maschinen-SPS oder ihr angeschlossenes SCADA-System.
→ Die Daten des Auftrags werden automatisch auf dem eingestellten Ablagelaufwerk abgelegt.


3 Grundlagen

SPS oder SCADA-System

Nach oben

OPC-UA-Server

Nach oben

Programmsuite certon

Nach oben
certon bietet dem Anwender die Möglichkeit Prozessdaten auftragsbezogen in einer Logdatei abzulegen (certonLOG bzw. certonLOG+)
und die Daten zu einem beliebigen Zeitpunkt zu analysieren und zu visualisieren (certonVIEW). Alle Einträge werden immer mit Datum,
Uhrzeit, Alt- und Neuwert sowie dem aktuellem Benutzer geloggt. Weiterhin kann der Aufzeichnungszeitpunkt (zyklisch, am Start, Ende,
bei Änderung etc.) frei gewählt werden.

Die Abbildung 1 zeigt schematisch die Anwendung der certon Software in einer typischen Prozessanwendung. Die Datenquelle(n), z.B. die
SPS der Maschinen (1), stellen die aufzuzeichnenden Daten (Logdaten) via OPC-UA -Server bereit (2). certon und seine Applikation (3) erfassen
die Daten und werten sie aus. Das Modul certonLOG bzw. certonLOG+ erfasst die gewünschten Daten bei Chargenstart und legt sie ab.
certonLOG+ signiert hierbei zusätzlich die erfassten Daten. Das Abfrageverhalten wird dabei mit einer CSV-Datei konfiguriert.
Dadurch ist anschließend eine nachträgliche Manipulation der Daten durch die Validierungsfunktion von certonVIEW erkennbar.
Mittels certonVIEW können die abgelegten Daten zu einem beliebigen Zeitpunkt angezeigt und analysiert werden. Aus certonVIEW heraus können
diese Daten mit Hilfe eines Reportgenerators kundenspezifisch dargestellt, ausgedruckt und in verschiedene Formate (z.B. PDF) exportiert werden.


3.1 Grundlegende Merkmale certonLOG(+)

certonLOG(+) hat folgende Merkmale:
  • •
    Verbindung zu Steuerungssystemen über eine einheitliche Schnittstelle (OPC UA)
  • •
    Ablage der Logdaten in eine separate Datei pro Logauftrag
  • •
    Mögliche Logverhalten:
  • •
    Intervallgesteuert
  • •
    bei Auftragsbeginn
  • •
    bei Auftragsende
  • •
    bei Änderung
  • •
    bei positiver oder negativer Flanke
  • •
    Verschiedene Logverhalten pro Datenpunkt kombinierbar
  • •
    Datenbanktyp: Firebird SQL
  • •
    Abtastrate Datenlogging Minimum: 1 Sekunde (bei Logverhalten Intervall)
  • •
    Empfohlene Anzahl Datenpunkte: <100 Werte/Sekunde


3.2 Funktionsweise certonLOG(+)

3.2 Funktionsweise certonLOG(+)

Erfassung durch certonLOG(+)

Nach oben

Erfassung

Nach oben

Speicherung als SQL-File

Nach oben

Signierung (certonLOG(+))

Nach oben

OPC-UA-Server

Nach oben

SCADA- oder SPS-Datenquellen

Nach oben
Das Modul certonLOG(+) erfasst, signiert und legt Chargen- bzw. Prozessdaten zur Auswertung durch certonVIEW auf einem Windows-PC mit
Intel-Prozessor ab. Dabei werden Prozess- bzw. Chargendaten aus Datenquellen (6) wie z.B. einer Maschinen-SPS mit dem Maschine-zu-Maschine
-Kommunikationsprotokoll OPC-UA mit einem Server (5) LAN-basiert zu dem PC (2) übertragen. certonLOG(+) fragt den OPC-UA-Server (5) ab
und erfasst OPC-UA-Daten wie Status- und Loggingdaten (1). Der Lifecounter erfolgt wechselseitig. Wird certonLOG(+) verwendet, werden die
Daten darüberhinaus zur Validierung signiert (4).
Anschließend werden die Daten zum vereinfachten Zugriff und zur Datenarchivierung in einer Variante des SQL-Datenformats abgespeichert (3).
Erfasste Daten werden danach mit certonVIEW ausgewertet, und können hier zum Erkennen von Manipulationen validiert werden.
Bei certonLOG(+) sind Informationen über die aufzuzeichnenden Daten, das Loggingverhalten, die Zugehörigkeit zu selbst definierten Gruppen und die
Übersetzungstexte dabei in einer textbasierten Konfigurationsdatei gespeichert, die der Benutzer editieren kann.


4 Installation und Konfiguration
Prüfen Sie vor der Installation die hier aufgelisteten Systemanforderungen! Vor der Installation neuer Software empfehlen wir die Sicherung wichtiger Daten.
Das gelieferte Softwarepaket certonLOG bzw. certonLOG(+) kann zu Testzwecken ohne Lizenz mit einer maximalen Aufzeichnungsdauer von 15 Minuten betrieben werden. Die Einschränkungen werden mit einer rechnerbezogenen Lizenz aufgehoben.

Für GMP-Compliance und GAMP 5 gibt es bei Benninger eine Funktionsspezifikation und (interne) Prüfprotokolle auf Nachfrage beim Support .


4.1 OPC-Server installieren und konfigurieren

certonLOG(+)
Benutzerhandbuch
×

4.1 OPC-Server installieren

Der OPC-Client dient als Schnittstelle zwischen SPS und certonLOG (+). Der OPC-Client ist Voraussetzung für die
Installation.

Installieren und konfigurieren Sie ihren erworbenen OPC-UA Server nach Herstelleranleitung!

Für den Import von Symboldateien können Sie für die OPC-Suite den Softing dataFEEDExporter
verwenden (Freeware).
Installieren und konfigurieren Sie ihren erworbenen OPC-UA Server nach Herstelleranleitung.
Für certon können Sie sämtliche OPC-Server verwenden. Wir empfehlen aus unserer Erfahrung die Verwendung der Softing datafeed OPC Suite.
Die Softing datafeed OPC Suite unterstützt die Betriebssysteme Microsoft Windows XP, Microsoft Windows 7, Microsoft Windows 8.1,
Windows Embedded 8.1 Industry, Windows 10, Microsoft Windows Server 2003, 2008 und 2012 R2.
Für Versuchszwecke ist auf dem Installationsmedium eine aktuelle Version der Softing datafeed OPC-Suite mitgeliefert. Sie kann zeitlimitiert im
Demomodus betrieben werden. Die Installation wird in den folgenden Kapiteln beschrieben.


4.1.1 Demoversion Softing datafeed OPC-Suite installieren

Wir empfehlen den Einsatz der Softing datafeed OPC-Suite aus Gründen der Kompatibilität. Für ihren Einsatz lässt sich aber jede vergleichbare Software verwenden.
Zur Installation der Demoversion (und auch der Vollversion, sofern Sie sie erworben haben) der Softing datafeed OPC Suite befolgen Sie
folgende Schritte:
  • 1.
    Starten Sie „dataFEEDOPCSuite_V_4_45“ vom mitgelieferten Datenträger (USB-Stick). Sie befindet sich im Verzeichnis „dataFEEDOPCSuite“
    auf dem USB-Stick im Ordner „    Installation“.
  • 2.
    Wählen Sie die Sprache und bestätigen Sie mit OK.
  • 3.
    Lesen Sie die Lizenzbedingungen bis zum Ende. Benutzen Sie dazu die Scrollleiste rechts (1).
  • 4.
    Drücken Sie die Schaltfläche "Akzeptieren" (2), wenn Sie die Lizenzbedingungen gelesen und verstanden haben.
    → Die Installation startet.
    5. Wählen Sie bei den Optionen den Safenet HASP Dongle-Treiber, wenn Sie die Software mit einem Dongle erworben und lizenziert haben.
    Unter "Speicherplatz" können Sie auch den vorhandenen Speicherplatz auf ihren Festplatten überprüfen.
    6. Klicken Sie auf die Schaltfläche "Weiter" und dann auf "Installieren".
4.1.1 Demoversion Softing datafeed OPC-Suite installieren

Bildlaufleiste

Nach oben

Lizenzvereinbarung annehmen

Nach oben
7. Geben Sie im Fenster Verwaltung und Aktivierung von Software-Lizenzen auf PCs den Lizenzschlüssel ein,
wenn Sie das Programm erworben haben.
8. Bestätigen Sie mit "Lizenz aktivieren".
→ Demoversion Softing datafeed OPC-Suite wird installiert.


4.1.2 Demoversion Softing datafeed OPC-Suite konfigurieren

Im Fenster "Funktionsauswahl" wird festgelegt, welche Funktionen der Client zur Verfügung stellen soll!

Nach der Installation befinden sich drei Software-Verknüpfungen Softing OPC Classic Demo Client, Softing OPC UA Client und
datafeed OPC Suite Konfigurator zu der Demoversion auf dem Desktop. Ein Systemtray-Icon dient dem Starten, Steuern und der
Konfiguration.
Zur Konfiguration der Demoversion (oder Vollversion, sofern Sie sie erworben haben) der Softing datafeed OPC Suite befolgen Sie
folgende Schritte:
  • 1.
    Legen Sie im Fenster "Funktionsauswahl" fest, welche Funktionen der Client zur Verfügung stellen soll.
    Wählen Sie dazu die entsprechenden Optionsfelder an.
  • 2.
    Wählen Sie im Programm die passende Datenquelle (SPS-Steuerung) wie z.B. Siemens an, und bestätigen Sie
    die Schaltfläche "    Datenquelle hinzufügen".
  • 3.
    Stellen Sie im Fenster Verbindungsassistent die Verbindung ein und wählen Sie das Applikationsprotokoll.
  • 4.
    Geben Sie im Fenster Kommunikationseinstellungen die IP-Adresse der verbundenen SPS an.
  • 5.
    Mit Betätigen der Schaltfläche "Ändern" lassen sich erweiterte Einstellungen vornehmen.
  • 6.
    Betätigen Sie die Schaltfläche "Weiter" und legen Sie im Fenster "Erweiterte Einstellungen" die Lesegeschwindigkeit fest.
    Mit dem Haken rechts unten können sie die Erreichbarkeit der SPS prüfen.
  • 7.
    Die Datenpunkte (-bausteine) der SPS importieren Sie mit Hilfe der projektspezifischen STEP-7-Datei.
  • 8.
    Importieren Sie dazu die passende Symboldatei aus dem STEP7-Projekt mit der Schaltfläche "Import" (unten rot).
    Die Datei musss sich innerhalb des Projektordners befinden.
  • 9.
    Wählen Sie dann das passende Step-7-Programm aus.
  • 10.
    Markieren Sie im Anschluss alle Datenpunkte mit dem Häkchen oben (rot umrandet).
    → Bei erfolgreichem Import wird jetzt ihre (DB-)Struktur dargestellt.
  • 11.
    Aktivieren Sie jetzt OPC UA (Menüpunkt Datenziele links oben). Unten können Sie ihrem Server auch einen Namen geben
    (Servername und Server Endpunkt hinter der Adresse).
  • 12.
    Stellen Sie jetzt darunter die Sicherheitseinstellungen ein. In der Regel sollten sie alle Optionen aktiviert haben.
    Im Fenster Zertifikate werden Anwendungszertifikate für den Transfer zu certonLOG(+) verwaltet. Hier wird das in der
    Einstellungsverwaltung von certonLOG(+) erstellte     Anwendungszertifikat importiert.
  • 13.
    Alle weiteren Einstellungen sind für eine erfolgreiche Funktionalität von certonLOG(+) nicht nötig.
  • 14.
    Starten Sie den Server mit dem Befehl "Start" im Menü Lokale Anwendung.
  • 15.
    Bei Bedarf können Sie den Server bei Start von Windows auch automatisch starten. Setzen Sie dazu den Haken beim Befehl beim Menüpunkt
    "Beim Windows-Start starten".
    16.Ist der Server gestartet, speichern Sie die aktuelle Konfiguration.
    → Der Server ist konfiguriert.
    17. Konfigurieren Sie certonLOG(+) und importieren Sie das erstellte Anwendungszertifikat im Fenster Zertifikate.

    Das grüne Ikon unten rechts im System-Tray zeigt an, dass der Server läuft. Hier können Sie den Server auch starten und stoppen.


4.2 certonLOG(+) installieren und lizensieren

certonLOG(+)
Benutzerhandbuch
×

4.2 certonLOG(+) installieren und lizenzieren
Installieren und Konfigurieren ist nur mit Administratorrechten möglich! Sie können in der Systemsteuerung unter "Benutzerverwaltung" ein Konto mit Administratorrechten anlegen.


4.2.1 certonLOG(+) installieren

Um certonLOG(+) zu installieren, führen Sie bitte die folgenden Schritte durch:
  • 1.
    Starten Sie „certonLOG_setup.exe“ bzw. „certonLOGPLUS_setup.exe“ vom mitgelieferten Datenträger (USB-Stick).
  • 2.
    Lesen Sie die Lizenzbedingungen bis zum Ende. Benutzen Sie dazu die Scrollleiste rechts.
  • 3.
    Drücken Sie die Schaltfläche "Akzeptieren", wenn Sie die Lizenzbedingungen gelesen und verstanden haben.
    → Die Installation startet.
  • 4.
    Folgen Sie den Installationsanweisungen auf dem Bildschirm.
  • 5.
    Nach erfolgter Installation wird das Konfigurationsinterface automatisch gestartet.


4.2.2 certonLOG(+) lizenzieren

Die Lizenzierung erfolgt bei certon pro Modul von certonLOG(+) arbeitsplatzbezogen. Somit gibt es für certonLOG(+) je eine Lizenz pro
Arbeitsplatz (certonVIEW benötigt keine Lizenz). Die Lizenzierung erfolgt mit einem im Softwarepaket enthaltenen Lizenzierungsmodul. Das
Lizenzierungsmodul wird über das separate Konfigurationsinterface von certonLOG(+) gestartet.
4.2.2 certonLOG(+) lizenzieren

Einstellungsverwaltung certon

Nach oben

Lizenzstatus

Nach oben

Produktschlüssel

Nach oben

1. Starten Sie die certon-Einstellungsverwaltung (1) mit Doppelklick auf das certonLog(+)-Icon auf dem Windows-Desktop.
→ Der angezeigte Lizenzstatus (2) steht auf „nicht lizenziert“.
3. Kopieren Sie den Produktschlüssel (3) mittels der Schaltfläche [image] in die Zwischenablage oder exportieren Sie ihn mittels
der Schaltfläche [image] als Textdatei zum Ausdruck.
4. Senden Sie den Produktschlüssel und die Lizenznummer auf dem erworbenen Lizenzschein online oder schriftlich an die Lizenzierungsstelle.
→ Sie erhalten die Lizenzierungsdatei "license.lic".
5. Importieren Sie die Lizenzdatei "license.lic" mit der Schaltfläche [image].
→ Sie erhalten die Lizenzierungsdatei "license.lic" und der Lizenzstatus (2) wechselt auf "lizenziert".
Hiermit ist die Lizenzierung abgeschlossen und es steht Ihnen der komplette Funktionsumfang von certonLOG bzw. certonLOG(+) zur Verfügung.


4.3 certonLOG(+) konfigurieren

Sie müssen certonLOG(+) unbedingt konfigurieren. Ohne Konfiguration lässt sich die Anwendung nicht verwenden.
Die Konfiguration ist nur mit Windows-Adminstratorrechten möglich. Unter "Benutzerverwaltung" können Sie in der Systemsteuerung ein Konto mit Administratorrechten anlegen.

Veränderte Einstellungen werden erst nach Neustart der Applikation übernommen!

Nach der Installation von certonLOG(+) oder durch Start der certonLOG(+)-Einstellungen öffnet sich die Einstellungsverwaltung. Hier wird die
Hilfe, die Versionsnummer und Testfunktionen aufgerufen (1), die Sprache ausgewählt (2), Dateipfade zur Hilfedatei (3), Konfigurationsdatei,
Speicherort und Arbeitsverzeichnis (4) eingestellt, der Server gewählt (5), die Lizenz aktiviert (6), das Signierzertifikat für certonLOG+
angezeigt (7) und das Anwendungszertifikat gespeichert und erstellt (8). Einstellungen können dabei exportiert und importiert werden (9).

Auf fehlende Einstellungen wird mit einem rot hinterlegten Hilfetext hingewiesen.
4.3 certonLOG(+) konfigurieren
1 Menü Hilfe und Testen
Nach oben

Sprache auswählen

Nach oben
Hilfedatei festlegen
Nach oben

Dateipfade konfigurieren

Nach oben

Server wählen

Nach oben

Lizenz aktivieren

Nach oben
Anzeige Signierzertifikat
Nach oben
Anzeige Anwendungszertifikat und Anwendungszertifikat erstellen
Nach oben
Einstellungen exportieren / importieren
Nach oben


4.3.1 Hilfe konfigurieren

certonLOG(+) wird mit Hilfedateien im pdf- und chm-Format ausgeliefert. Sie können je nach Präferenz die Hilfe in einem
der beiden Formate verwenden, oder bei Bedarf auch eigene Dateien als Hilfedateien einbinden.

Zum Aufrufen der Hilfe von certonLOG(+) muss zuerst der Speicherort der Hilfedatei angegeben werden:

1. Betätigen Sie zur Angabe des Speicherorts zuerst die Schaltfläche "Hilfedatei festlegen" (2).
2. Wählen Sie jetzt die Hilfedatei aus. Normalerweise ist dies die mitgelieferte Hilfe im chm- oder pdf-Format. Sie befindet sich im Regelfall
am Speicherort, an dem certonLOG(+) installiert ist (z.B. C:\Program Files\certon). Wenn Sie eine eigene Hilfedatei verwenden wollen,
wählen Sie dazu den Speicherort dieser Datei.
3. Betätigen Sie nach Auswahl die Schaltfläche "Öffnen" im Dateiauswahl-Dialog von Windows.

→ Die Hilfedatei ist festgelegt und kann verwendet werden.
Ist die Hilfedatei ausgewählt, kann Sie mit dem Menüpunkt "Hilfe" im Menü Hilfe (2) ausgewählt werden.
4.3.1 Hilfe konfigurieren

Hilfedatei festlegen

Nach oben

Menü Hilfe

Nach oben


4.3.2 Anwendungs- und Signierzertifikat
Um eine „sichere Verbindung“ zwischen certonLOG(+) und dem OPC Server zu gewährleisten, ist das Anwendungs-Zertifikat von certonLOG(+) als "trusted" / vertrauenswürdiges Zertifikat beim OPC Server hinzuzufügen. Beachten Sie dazu auch das Handbuch des eingesetzten OPC Servers.

Das Signierzertifkat wird nur von certonLOG+ verwendet. Mit ihm werden im Logprozeß die Daten zur Validierung signiert (verschlüsselt). Zur Verschlüsselung wird ein Hash-Algorithmus eingesetzt. Eine Konfiguration ist nicht nötig.
Das Anwendungszertifikat dient zur Zertifizierung bei der Übertragung von OPC-UA-Daten von Server zu certonLOG+. Es wird in der
Einstellungsverwaltung von certonLOG(+) erstellt, und nachher in den OPC-Server importiert .
  • 1.
    Betätigen Sie zum Erstellen des Anwendungszertifikats die Schaltfläche "Neues Anwendungszertifikat erstellen" (1).
4.3.2 Anwendungs- und Signierzertifikat

Anwendungszertifakt erstellen

Nach oben
→ Das Anwendungszertifikat wird erstellt.
2. Importieren Sie das Anwendungszertifikat in ihren OPC UA Server. Bei Verwendung der Softing datafeed OPC-Suite folgen Sie
 diesen Anweisungen .
→ Das Anwendungszertifikat ist importiert.
Das Signierzertifikat wird ausschließlich von certonLOG+ zur Verschlüsselung verwendet und wird nicht konfiguriert.


4.3.3 Server auswählen und einstellen
Ist certonLOG(+) nicht konfiguriert, lässt sich die Anwendung nicht verwenden. Konfigurieren Sie die Anwendung vor Verwendung.

Die Verschlüsselungsarten müssen vorher im Einstellungsmenü des verwendeten OPC-Servers konfiguriert werden!
Zur Verbindungsherstellung muss evtl. auf dem Rechner des Quelldatenservers eine vorhandene Firewall konfiguriert werden!
Bei Ersteinstellung oder Konfigurationsänderung muss eine neue Server-Datenverbindung eingestellt werden.
Folgende Voraussetzungen müssen gegeben sein:
  • •
    OPC-Server installiert
  • •
    Anwendungszertifikat beim OPC-Server importiert
    4.3.3 Server auswählen und einstellen

Menü Testen

Nach oben

Serververwaltung

Nach oben

Schaltfläche Server wählen

Nach oben
  • 1.
    Betätigen Sie zur Auswahl des Servers die Schaltfläche "Wählen" (3) und dann "Server hinzufügen" (2).
  • 2.
    Geben Sie die IP-Adresse des Servers in das Eingabefeld URL ein. Klick auf das Lupen-Ikon sucht dann
    nach dem eingegebenen Server.
  • 3.
    Wählen Sie den Server aus der Liste aus und stellen Sie die Verschlüsslungsart (Encoding) ein.
  • 4.
    Übernehmen Sie mit der Schaltfläche "Hinzufügen" den Server in die Auflistung.
  • 5.
    Im Serverauswahlfenster können mit der Schaltfläche "Server hinzufügen"
    weitere Server hinzugefügt werden. Server können hier auch kopiert und entfernt werden.
  • 6.
    Mit der Schaltfläche "Verbindung testen" oder dem Menüpunkt "Serververbindung testen" (1) kann die
    Verbindung getestet werden.
→ Die OPC-Serververbindungsaufnahme wird mit den angezeigten Einstellungen überprüft und das Resultat angezeigt.
Beim erstmaligen Verbindungstest wird der Benutzer dazu aufgefordert das Zertifikat, zu prüfen. Klicken Sie in diesem Fall auf die Schaltfläche "Vertrauen".
→ Das Zertifikat ist jetzt anerkannt.
Die Verbindung ist jetzt getestet und kann verwendet werden.


4.3.4 Konfigurationsdatei bearbeiten

Wir empfehlen ein Arbeiten mit LibreOffice. Das Programm ist als OpenSource/Freeware-Programm umsonst und kann im Internet bezogen werden.
certonLOG(+) wird mit einer Datei im textbasierten CSV-Format konfiguriert. Mit der Datei werden die Datenquellen bzw. die einzelnen
Variablen festgelegt. Damit wird dann, letzlich mit einem konfigurierten Abfrageverhalten, eine Datenquellen wie z.B. eine Maschinen-SPS
prozessgesteuert abgefragt.
Der Speicherort der CSV-Datei wird in der Einstellungsverwaltung festgelegt. Für Variablen werden dabei Bezeichner vergeben (Identifier),
denen Werte wie z.B. die OPC URI (Adresse) zugeordnet werden. Für jede Variable kann eine Benennung vergeben werden.
Die Benennung kann in beliebig viele Landesprachen übersetzt werden. Dazu wird ein LCID-Code (Local ID-Code) verwendet.


Aufbau Konfigurationsdatei (CSV)

Die CSV gliedert sich dabei in vier Bereiche. Der erste Bereich ist die MainConfig mit den zu loggenden Verbindungsinformationen zur SPS (1).
Der zweite Bereich ist die GroupConfig (2). Hier wird definiert, wie und wann eine Variable aufgezeichnet wird. Im dritten Bereich, der
TagConfig (3), stehen die Variablen, die geloggt und aufgezeichnet werden sollen. Den Abschluss bildet der Bereich certon Messages (4).
Dies sind von Benninger definierte Fehlermeldungstexte, die nicht geändert werden sollten. Benennungen befinden sich in
extra Spalten (5).
Aufbau Konfigurationsdatei (CSV)

MainConfig

Nach oben

GroupConfig

Nach oben

TagConfig

Nach oben

CertonMessages

Nach oben

Spalte Benennung und LCID-Code

Nach oben


MainConfig
Die Variablen der Mainconfig müssen in der Loggingkonfiguration beschrieben sein! Andernfalls gibt es Fehlermeldungen.
Der erste Bereich oder Abschnitt der CSV-Datei ist die MainConfig. In diesem Tabellenabschnitt sind zentrale Variablen wie z.B. "Status CMD"
(Steuerung Logging) beschrieben, welche zur Identifikation der geloggten Daten und zur Steuerung der Datenaufzeichnung nötig sind.
Spalten
Die erste Spalte der MainConfig enthält den Identifier (1). Der Identifier ist in der MainConfig vorgegeben, und ist in jeder CSV identisch.
Die zweite Spalte ist der OPC Namespace (2) mit dem Namen des OPC-Servers. In der dritten Spalte "OPC Uri" (3) stehen
die OPC-URIs. Von ihnen werden die Informationen bezogen.
MainConfig

Spalte Identifier

Nach oben

Spalte OPC Namespace

Nach oben

Spalte OPC Uri

Nach oben
Zentrale Variablen
Folgende zentrale Variablen werden im Abschnitt MainConfig verwendet (als Beispiel mit dem OPC-Namespace SPS_1):

Identifier

OPC Namespace

OPC Uri

Bedeutung

BATCHNAME

SPS_1

.Chargendaten.Batchname

Name Batch/Auftrag

BATCHNUMBER

SPS_1

.Chargendaten.Batchnumber

Eindeutige Nummer zur Identifikation

PRODUCTNAME

SPS_1

.Chargendaten.Produktname

Produktname

RECIPE

SPS_1

.Chargendaten.Recipename

Name des Rezepts oder des Basisprozesses

STATUS_CMD

SPS_1

.Chargendaten.Status_Certon_Log_Command

aktuelles Kommando, mit der das Logging angesteuert wird

STATUS_STAT

SPS_1

.Chargendaten.Status_Certon_Log_State

Rückmeldung Bearbeitungsstatus Loggingmodul

OPERATOR

SPS_1

.Chargendaten.Benutzer

Aktueller Bediener, der die Charge bearbeitet

LIFECOUNTER_IN

SPS_1

.Data.CounterToCerton

überprüft Verbindung zur SPS, Werteänderung minimal alle 500 ms

LIFECOUNTER_OUT

SPS_1

.Data.CounterFromCerton

überprüft Verbindung zum certon-Loggingmodul. LIFECOUNTER_IN wird hierüber zurück geschrieben.

Logging-Kommandos mit STATUS_CMD und der rückgemeldete Bearbeitungstatus von certonLOG(+) mit STATUS_STAT werden als
Kombination verschiedener Bitmuster ausgebaut bzw. ausgewertet. Das Statusbit Loglauf ist dabei dominant (prägend).

Wert

Reserve 2

Reserve 2

Loglauf (dominant)

Status Resultat

0

Ende

1

x

Lauf (Logstart)

2

x

Ende

3

x

x

Lauf (Logstart)

4

x

Ende

5

x

x

Lauf (Logstart)

6

x

x

Ende

7

x

x

x

Lauf (Logstart)
(c) Benninger Automation, 2019


GroupConfig
Seit der Version 2.2.705.25 erkennt certonLOG(+) nachfolgende Schlüsselwörter und bringt bei falschen oder falsch geschriebenen Schlüsselwörtern eine Fehlermeldung. Falsch geschriebene optionale Argumente im ON_CHANGE-Schlüsselwort und zu kleine Intervalle beim ON_INTERVAL-Schlüsselwort werden ebenfalls erkannt.

Der Identifier muss frei gewählt und eindeutig definiert werden und darf nicht mehr als 15 Zeichen enthalten!

Die Zeile CERTON_MESSAGES darf nicht verändert werden!

Im Tabellenabschnitt GroupConfig werden Logdaten-Gruppen mit den typischen certon-Loggingmerkmalen vordefiniert. Den Gruppen werden
nachher im Abschnitt TagConfig die jeweiligen einzelnen Variablen zugeordnet. Das eingestellte (Logging-)Verhalten wird dann an die den
Gruppen zugeordneten Variablen weiter gegeben.
Aufbau
In der ersten Spalte unter [GroupConfig] (1) kann der Identifier (Gruppenname) vom Benutzer formuliert werden. Er sollte eindeutig sein und nicht
mehr als 15 Zeichen beinhalten. In den Spalten Texte/Übersetzungen (4) werden die Bezeichnungen für die Identifier in den jeweiligen Sprachen
angezeigt. Die Sprachen werden dabei mit einem LCID-Code (5) definiert. Es können beliebig viele Sprachen angelegt werden.

In der Spalte "Behaviour" (2) wird mit Schlüsselwörtern (3) das Aufzeichnungsverhalten der Gruppe definiert. Zahlen oder Zeitangaben werden
ergänzend verwendet. Beim Intervalloggen wird nur ein Zahlenwert eingegeben (6).
Die Schlüsselwörter sind dabei:
  • •
    ON_START und ON_END loggen die Werte am Anfang bzw. am Ende der Charge.
  • •
    ON_CHANGE loggt immer, wenn sich der Wert der Variable verändert.
  • •
    ON_EDGE_R loggt die Werte, wenn deren Flanke sich erhöht, also die Werte steigen.
  • •
    ON_EDGE_F loggt die Werte, wenn deren Flanke sinkt, also die Werte fallen.
Schlüsselworte und auch Zahlenwerte werden kombiniert bzw. addiert (siehe unten).

Spalte Identifier

Nach oben

Spalte Behaviour

Nach oben

Schlüsselwort

Nach oben

Spalte Texte/Übersetzungen

Nach oben

LCID-Code (Deutschland)

Nach oben

Abtastrate Intervall

Nach oben
Aufzeichnungsverhalten
Das Aufzeichnungsverhalten wird mit Schlüsselworten bestimmt. Aus Gründen der Abwärtskompatibilität können auch Zahlenwerte
verwendet werden. Benötigt man eine Kombination verschiedener Aufzeichnungsverhalten, werden Zahlenwerte addiert.
Beispiel:
ON_END, ON_CHANGE ist als Zahlenwert -6 (-2+-4). Damit werden die Variablen einer Gruppe bei Änderung und am Ende des Batch/Auftrags
geloggt.
Aufzeichnungsverhalten | Schlüsselwort | Beschreibung | Zahlenwert(e)
Intervall | Zeitwert | Loggt die Variablen im angegebenen Intervall, Kombination mit anderen Aufzeichnungsarten ist nicht möglich. | Angaben in Sekunden. Nur positive Ganzzahlen verwenden. Bei Wert 0 erfolgt keine Aufzeichnung.
Anfang der Charge | ON_START | Loggt alle Variablen der Gruppe beim Beginn eines neuen Logauftrags. | -1
Bei Wertänderung | ON_CHANGE [SamplingInterval, DeadBand] | Loggt die Variablen bei Wertänderung. Das SamplingInterval bestimmt die Zeit zwischen zwei Prüfungen. DeadBand bestimmt die zur Aufzeichnung nötige minimale Wertänderung. SamplingInterval und DeadBand sind optional. Falls kein Intervall angegeben wird, wird der Defaultwert von 200ms verwendet. | -2 Zeitwert für <SamplingIntervals>, Dezimalwert für <DeadBand>.
Ende der Charge | ON_END | Loggt alle Variablen der Gruppe beim Beenden eines Logauftrags. | -4
Wertänderung positiv | ON_EDGE_R | Die Werte einer Gruppe mit diesem Verhalten werden sofern möglich in einen Bool konvertiert. Wechselt dieser Bool-Wert von FALSE auf TRUE wird der Wert aufgezeichnet (Flanke steigend). | -8
Wertänderung negativ | ON_EDGE_L | Die Werte einer Gruppe mit diesem Verhalten werden sofern möglich in einen Bool konvertiert. Wechselt dieser Bool-Wert von TRUE auf FALSE wird der Wert aufgezeichnet. | -16
Mögliche Kombinationen
Wert | Am Batch- bzw. Auftragsende (ON_END) | Bei Änderung (ON_CHANGE) | Positive Flanke (ON_EDGE_R) | Negative Flanke (ON_EDGE_R) | Bei Batch- bzw. Auftragsstart (ON_START)
-1 |  |  |  |  | x
-2 |  | x |  |  |
-3 |  | x |  |  | x
-4 | x |  |  |  |
-5 | x |  |  |  | x
-6 | x | x |  |  |
-7 | x | x |  |  | x
-8 |  |  | x |  |
-9 |  |  | x |  | x
-10 |  | x | x |  |
-11 |  | x | x |  | x
-12 | x |  | x |  |
-13 | x |  | x |  | x
-14 | x | x | x |  |
-15 | x | x | x |  | x
-16 |  |  |  | x |
-17 |  |  |  | x | x
-18 |  | x |  | x |
-19 |  | x |  | x | x
-20 | x |  |  | x |
-21 | x |  |  | x | x
-22 | x | x |  | x |
-23 | x | x |  | x | x
-24 |  |  | x | x |
-25 |  |  | x | x | x
-26 |  | x | x | x |
-27 |  | x | x | x | x
-28 | x |  | x | x |
-29 | x |  | x | x | x
-30 | x | x | x | x |
-31 | x | x | x | x | x


TagConfig

Die CSV funktioniert nur dann, wenn der jeweilige Datenpunkt auch auf dem Server und der SPS vorliegt!

Die Adressangaben sind je nach eingesetztem OPC-Server unterschiedlich zu strukturieren. Zum Beispiel muss bei einigen OPC-Servern der OPC Namespace führend angegeben werden.
In den Tabellenabschnitt TagConfig werden die vom Anwender definierten Logvariablen eingetragen. In der ersten Spalte Identifier (1) stehen die
Namen der Variablen, die geloggt und aufgezeichnet werden sollen. Der Identifier muss frei gewählt und eindeutig definiert werden und darf nicht
mehr als 25 Zeichen enthalten.

In der Spalte OPC Namespace (2) steht der Namespace des OPC-Servers, wie z.B. Siemens_1. Unter OPC Uri (3) stehen die OPC-Adressen
der Variablen. Die Zuordnung muss für jede Variable erfolgen.
In der Spalte Group (4) wird den Tags wie z.B. START1 eine Gruppe aus der GroupConfig wie z.B. EQUIPMENT zugeteilt. Jedem Tag kann dabei
nur eine Gruppe zugeordnet werden. In der Spalte Unit (5) können den Variablen Maßeinheiten zugeordet werden. Texte/Übersetzungen stehen in
der folgenden Spalte (6). Jede Sprache verwendet dabei eine eigene Spalte mit zugeordnetem LCID-Code . Es können so viele Übersetzungen/
Sprachen eingegeben werden, wie gewünscht.

Spalte Identifier

Nach oben

Spalte Behaviour

Nach oben

Spalte OPC Uri

Nach oben

Spalte Group

Nach oben

Spalte Unit

Nach oben

Spalte Texte/Übersetzungen mit LFID

Nach oben


CertonMessages
Der Eintrag Identifier ist eine interne Variable und darf nicht gelöscht werden!
Im Tabellenabschnitt CertonMessages werden von certonLOG(+) generierte und in die Logdatei eingetragene Systemmeldungen festgelegt.
Die hier definierte Struktur darf vom Benutzer deswegen nicht verändert werden. Definierte Meldetexte lassen sich allerdings erweitern.
Die erste Spalte von CertonMessages enthält den Identifier (1). Der Identifier ist eine interne Variable, ist damit vorgegeben und darf nicht
gelöscht werden. Die zweite Spalte sind deutsche Meldetexte (2). In der dritten Spalte befinden sich normalerweise die englischen
Meldetexte (3).

Für weitere Sprachen können beliebig viele Übersetzungen in Spalten mit LCID-Code eingegeben werden.

Spalte Identfier

Nach oben

Meldetexte deutsch

Nach oben

Meldetexte englisch

Nach oben

Identifier in CertonMessages

[CertonMessages] |
Identifier | 1031
CERTON_SPS_HALT | SPS Lifecounter zählt nicht hoch
CERTON_INT_BREAK | Chargenaufzeichnung wurde vom Benutzer unterbrochen
CERTON_LOGFILE_ERROR | Fehler beim Eintragen in Datenbank
CERTON_OPC_ERROR | Fehler bei OPC
CERTON_TIMING_ERROR | Das System konnte die Taktung für die Datenaufnahme nicht einhalten
CERTON_INT_CLOSE | Chargendaten werden nach Unterbrechung gespeichert
CERTON_INT_CONTINUE | Auftrags/Chargendaten werden nach Unterbrechung weiter aufgezeichnet
CERTON_INT_LATESTART | Logging startet und Auftrag/Charge läuft bereits
CERTON_START_LOGGING | Loggingstart
CERTON_STOP_LOGGING | Loggingende


4.3.5 CSV-Datei öffnen

Verwenden Sie zur Konfigurierung bevorzugt die Freeware LibreOffice! MS-Excel setzt nach jedem Öffnen die Schriftkodierung zurück, und verursacht Fehler.

Für den Import sollte eine CS immer den Zeichensatz Unicode UTF-8 aufweisen und als Trennoption ein Semikolon verwenden.

CSV-Datei öffnen
Mit der von uns empfohlenen Freeware LibreOffice importieren Sie eine CSV-Datei wie folgt:
  • 1.
    Starten Sie LibreOffice vom Windows-Desktop mit Doppelklick auf die Verknüpfung "LibreOffice".
  • 2.
    Importieren Sie die CSV-Datei. Die CSV-Datei wird mit dem Dateipfad "Konfigurationsdatei"
    in der     Einstellungsverwaltung (certonLOG(+)-Einstellungen) festgelegt.
  • 3.
    Betätigen Sie in LibreOffice die Schaltfläche "Datei öffnen" und navigieren Sie zum Verzeichnis,
    in dem sich die CSV-Datei befindet (Dateipfad der Konfigurationsdatei).
  • 4.
    Öffnen Sie die CSV-Datei in der Dateiauswahl mit der Schaltfläche "Öffnen".
    →Der LibreOffice-Dialog "Textimport" öffnet sich.
  • 5.
    Achten Sie darauf, dass die Trennoption Semikolon angewählt ist und der Zeichensatz Unicode
    (UTF-8)    . Andernfalls gibt es Probleme.
  • 6.
    Bestätigen Sie den Import mit der Schaltfläche "OK".
→Die CSV-Datei wird in LibreOffice geöffnet.


4.3.6 CSV-Datei bearbeiten und prüfen

Innerhalb der CSV-Tabellenabschnitte dürfen keine Leerzeilen oder Leerspalten eingefügt werden!
Die Konfigurationsdatei muss nach der Eingabe validiert werden, andernfalls erfolgen Fehlermeldungen!

Werte eingeben
CSV-Dateien werden in der von uns empfohlenen Tabellenkalkulation von LibreOffice wie in Excel bearbeitet: In Zellen werden Werte eingegeben.
Für Umsteiger eine kurze Anleitung:
  • 1.
    Wählen Sie zum Bearbeiten in LibreOffice eine Zelle mit einem Wert (3) aus.
  • 2.
    Ändern Sie den Wert oben in der Eingabezeile (2).
  • 3.
    Wiederholen Sie die Schritte 1 und 2 für sämtliche einzugebenden Werte in den vier Teilen der CSV (siehe Kapitel " Aufbau CSV ").
    → Werte sind eingegeben.
  • 4.
    Speichern Sie die Datei mit der Schaltfläche Speichern (1).
    4.3.6 CSV-Datei bearbeiten und prüfen

    Datei speichern

    Nach oben

    Eingabezeile

    Nach oben

    Zelle mit Variable

    Nach oben
CSV validieren (prüfen)
Zum Validieren der CSV wird die Einstellungsverwaltung von certonLOG(+) verwendet.
  • 1.
    Öffnen Sie die Einstellungsverwaltung von certonLOG(+).
  • 2.
    Stellen Sie den Pfad zur gerade bearbeiteten CSV her (siehe Kapitel "certonLOG(+) konfigurieren ").
  • 3.
    Starten Sie die Validierung mit dem Menüpunkt CSV Konfiguration testen im Menü Testen. Bei Fehlern erfolgt eine Fehlermeldung.
    Überarbeiten Sie in diesem Fall die Datei in LibreOffice (s.o.).
  • 4.
    Erfolgt keine Fehlermeldung, kann die CSV verwendet werden.
    → Konfigurationsdatei ist bearbeitet und geprüft.


4.3.7 Verhalten für Logging- Altwerte konfigurieren

Ab certonLOG(+) 2.2.705.25 werden vor dem Start des Logs die aktuellen (statt die zuletzt geloggten)
Variablenwerte für alle Variablen vom OPC-Server abgerufen. Dies kann mit einer Einstellung in der Konfigurationsdatei "settings.json" geändert werden.
Ab certonLOG(+) 2.2.705.25 ist das Loggingverhalten verändert. Vor dem Start des Logs werden grundsätzlich die aktuellen Variablenwerte für
alle Variablen vom OPC-Server abgerufen. Ist der Parameter "KeepOldValuesOnStart" in der Konfigurationsdatei "settings.json" auf 1 gesetzt werden,
werden, wie früher, die zuletzt geloggten (aufgezeichneten) Altwerte verwendet.
Um die zuletzt geloggten Altwerte zu verwenden, folgende Schritte durchführen:
1. Die Datei "settings.json" in "C:\ProgramData\certon\certonLOG (PLUS)" bzw. "C:\Program Files (x86)\certon\certonLOG (PLUS)" (Win7)
mit einem Texteditor öffnen.
2. Den Wert “KeepOldValuesOnStart” von 0 auf 1 setzen.
→ Beim Start eines Logs übernimmt certonLOG(+) jetzt den letzten Wert des vorherigen Logs als Altwert der Variable, anstatt
des aktuellen Variablenwerts, vom OPC-Server.


4.4 Neue Landessprache anlegen
Wir empfehlen ein Arbeiten mit LibreOffice. Das Programm ist als OpenSource/Freeware-Programm umsonst und kann im Internet bezogen werden.
Die Konfiguration der Sprachdatei ist nur mit Windows-Adminstratorrechten möglich. Unter "Benutzerverwaltung" können
Sie in der Systemsteuerung ein Konto mit Administratorrechten anlegen.
In der Menüführung von certon werden eigene Landessprachen verwendet. Programminterne Bezeichner können daher in verschiedenen
Landessprachen angelegt werden.

Zum Anlegen einer neuen Sprache werden die Bezeichnernamen in der neuen Sprache in der Sprachdatei "lang.csv" angelegt. Die
Übersetzung wird dazu mit einem (LCID-)Nummerncode für die verwendete Sprache gekennzeichnet.


4.4.1 Sprachdatei öffnen
Die Konfiguration der Sprachdatei ist nur mit Windows-Adminstratorrechten möglich. Unter "Benutzerverwaltung" können Sie in der Systemsteuerung ein Konto mit Administratorrechten anlegen.
Sollte LibreOffice die importierte Datei lang.csv nur als Textdatei anzeigen, navigieren Sie in das Verzeichnis und importieren Sie über die Funktion "Öffnen mit" (rechte Maustaste). Damit funktioniert der Import im Tabellenformat.

Im Folgenden wird exemplarisch das Öffnen mit LibreOffice gezeigt.
  • 1.
    Starten Sie LibreOffice vom Windows-Desktop mit Doppelklick auf die Verknüpfung "LibreOffice".
2. Betätigen Sie die Schaltfläche „Datei öffnen“ und navigieren Sie zum Verzeichnis, in dem sich die CSV-Datei lang.csv befindet
(normalerweise unter "C:\Program Files (x86)\certon\certonLOG Plus" oder "C:\Program Files (x86)\certon\certonLOG").
3. Öffnen Sie die CSV-Datei in der Dateiauswahl mit der Schaltfläche "Öffnen".
→Der Dialog "Textimport" erscheint.
4. Achten Sie darauf, dass die Trennoption Semikolon angewählt ist und der Zeichensatz Unicode (UTF-8). Andernfalls gibt es Probleme.
5. Bestätigen Sie den Import mit der Schaltfläche "OK".
→Die CSV-Datei wird in LibreOffice geöffnet. Sie kann jetzt bearbeitet werden.


4.4.2 Übersetzung für neue Sprache eingeben

Sprachen und Übersetzungen für Texte werden in Excel oder in der von uns empfohlenen Software LibreOffice mit der Datei "lang.sv" eingegeben. Im Folgenden wird exemplarisch das Bearbeiten mit LibreOffice gezeigt.
Sollte LibreOffice die importierte Datei "lang.csv" nur als Textdatei anzeigen, navigieren Sie in das Verzeichnis und importieren Sie über die Funktion "Öffnen mit" (rechte Maustaste). Damit funktioniert der Import im Tabellenformat.
Im Folgenden wird exemplarisch das Lokalisieren bzw. Eingeben einer neuen Übersetzung mit LibreOffice gezeigt. Die Dateneingabe erfolgt
ähnlich wie in MS-Excel.
  • 1.
    Geben Sie in die Zeile Sprachcode (1) den Sprachcode für die neue Sprache ein. Sie finden den Sprachcode im Anhang .
  • 2.
    Geben Sie in die Spalte darunter (2) die Übersetzung für den Bezeichner in der neuen Landessprache ein.
  • 3.
    Wiederholen Sie den Schritt 2 für sämtliche einzugebenden Übersetzungen.
    → Neue Übersetzung ist eingegeben.
  • 4.
    Speichern Sie die Datei mit "Speichern" im ursprünglichen Verzeichnis.

    → Lokalisierung bzw. neue Landessprache ist angelegt.
    4.4.2 Übersetzung für neue Sprache eingeben

    Sprachcode (LFID)

    Nach oben

    Spalte Übersetzung

    Nach oben

    Bezeichner

    Nach oben


5 Bedienung

certonLOG(+)
Benutzerhandbuch
×

5 Bedienung und Verwendung
Im Programm können Sie mit dem Icon „?“ unter dem Menüpunkt „Hilfe“ auf das von Benninger zur Verfügung gestellte Handbuch oder eine eigene Hilfedatei zugreifen. Unter dem Menüpunkt „Info“ finden Sie hier auch die aktuelle Programmversion.

Der Ablagepfad und der Pfad zur Hilfe wird in der Konfiguration angegeben (siehe Kapitel " Konfiguration ")!

Beim Start von certonLOG(+) wird die Programmoberfläche angezeigt. Mit dem Ikon „?“ können Sie auf das Menü Hilfe und damit
Versionsinfo und die integrierte Hilfe zugreifen (1). Unter Quelle (OPC) wird Auftragsname und -nummer, das Produkt, das Rezept, Bediener
und Loggingstatus, die Serveradresse und der Verbindungsstatus angezeigt (2). Grün bedeutet dabei ok, rot fehlerhaft.
Auftrag, Auftragsnummer, Produkt, Rezept und Startzeit werden im Feld Auftrag (3) angezeigt, Informationen über den Ablagepfad und den
freien Speicher im Feld Ablagepfad darunter (4). Erstellungs-, Signierungs-, und Speicherpuffer werden darunter angegeben (5).

Hilfe und Versionsinfo

Nach oben

Quelle (OPC)

Nach oben

Auftrag

Nach oben

Informationen Ablagepfad

Nach oben

Pufferinformationen

Nach oben


5.1 certonLOG(+) starten

Voraussetzungen:
  • •
    OPC-Server installiert
  • •
    certonLOG(+) eingestellt und konfiguriert
  • •
    SPS oder SCADA-System angeschlossen und bereit
Starten
Zum Starten von certonLOG(+) führen Sie folgende Schritte aus:
  • 1.
    Klicken Sie mit dem Mauszeiger auf dem Windows-Desktop (doppelt) auf das Ikon "certonLOG".
→ certonLOG(+) startet, und das Logo certonLOG(+) erscheint.
Nach Lizenzüberprüfung und Verbindung mit dem OPC-Server erscheint die Bedienoberfläche von
certonLOG(+):

→ certonLOG(+) ist gestartet.


5.2 certonLOG(+) verwenden

Voraussetzungen:
  • •
    OPC-UA-Server installiert
  • •
    certonLOG(+) eingestellt und konfiguriert
  • •
    Datenquelle (SPS oder SCADA-System) sendefähig oder sendet Daten
Prozess/Chargendaten aufnehmen
1. Starten Sie die Maschinen-SPS oder ihr angeschlossenes SCADA-System. Die Aufzeichnung wird mittels Signaländerung Loggingstatus
gestartet.
→ Die Daten des Auftrags (3) werden automatisch auf dem eingestellten Ablagelaufwerk (Verzeichnis) (4) abgelegt.
2. Läuft der Loggingprozess bereits und sendet Daten, wird automatisch direkt in dem Verzeichnis (4) aufgezeichnet. certon vermerkt in
diesem Fall, dass schon vor Programstart OPC-UA-Daten gesendet wurden.
→ Die Daten werden aufgezeichnet bzw. "geloggt".
5.2 certonLOG(+) verwenden
(c) Benninger Automation, 2019


5.3 certonLOG(+) mit Startparametern anpassen

certonLOG und certonLOG(+) können zur Anpassung mittels Startup-Parameter(Kommandozeilenparameter) gestartet werden.
Folgende Parameter stehen dabei zur Verfügung:
--quiet Unterdrückt die „Sicherheitsabfrage“ beim Beenden der Anwendung.
--nosplash Startet ohne Anzeige des Startbildschirms (Splashscreen).
--minimized Startet mit minimierten Hauptfenster.
--triggerontimestamp Beim Loggen auf Änderung wird auch auf den Zeitstempel (wann der Wert gelesen wurde) geschaut. Ist dieser neuer, wird
der Datenpunkt geloggt, auch wenn sich der Wert sonst nicht geändert hat (standardmäßig wird nur auf den Wert geschaut).
Beispiel Kombination Startup-Parameter: “certonLOG.exe” --quiet –nosplash
Um ein Kommandozeilenparameter zu verwenden, verwenden Sie die Windows-Eingabeaufforderung.
  • 1.
    Drücken Sie die Tastenkombination [Win] + [R].
    → Die Windows-Eingabeaufforderung "Ausführen" wird angezeigt.
  • 2.
    Ziehen Sie das Verknüpfungs-Ikon certonLOG(+) auf das Feld "Öffnen".
  • 3.
    Fügen Sie den gewünschten Kommandozeilenparameter hinzu (s.o.) und drücken Sie "OK".
  • 4.
    Starten Sie certonLOG(+) mit Doppelklick auf das Ikon.
    → certonLOG(+) wird mit dem gewünschten Kommandozeilenparameter gestartet und entsprechend angepasst.


5.4 certonLOG(+) mit Batchdateien verwenden

Beachten Sie, dass Sie zur Verwendung von Batchdateien die Windows-Zugriffsrechte gewährleistet sind!

Verwenden Sie als Vorlage die Beispiele " LogStarted.bat " und " LogStopped.bat " in Verzeichnis "hooks".
certonLOG(+) bietet die Möglichkeit, bei besonderen Ereignissen im Programmablauf eigene, in Batchdateien programmierte Aktionen
(Hooks), wie z.B. bei Logstart ein weiteres SQL-Logfile aufnehmen, auszuführen. Die Aktionen/Hooks blockieren die Ausführung von
certonLOG(+) dabei nicht.
Beim Aufruf eines Hooks werden den Batchdateien verschiedene Daten als Parameter übergeben; das Arbeitsverzeichnis der Hooks ist das
temporäre Systemverzeichnis entsprechend der Umgebungsvariable %TEMP%. Alle relativen Pfade werden zu diesem Verzeichnis aufgelöst.
Hook-Vorlagen verwenden
Zur Verwendung von Hooks passen Sie am besten die mitgelieferten Vorlagen an.
1. Öffnen Sie dazu das Unterverzeichnis hooks (1) im Verzeichnis certonLOG(+).
2. Öffnen Sie eine der Vorlagendateien wie z.B. LogStarted.bat (2) mit Doppelklick.
→ Die Datei wird im (Windows-)Editor angezeigt.
3. Verändern Sie die Datei nach den Vorlagen unten im Kapitel " Beispiele Hooks und Batchdateien ", sofern nötig.
4. Wenn dies noch nicht erfolgt ist, muss zum Aktivieren die Endung ".txt“ vom Dateinamen entfernt werden, so dass die Datei auf ".bat“ endet.
→ Der Hook (in Batchdatei programmierte Aktion) wird jetzt im Programmablauf ausgeführt.


5.4.1 Beispiele Hooks und Batchdateien

Verwenden Sie die kommentierten Beispiele als Vorlage für Anpassungen und eigene Programmierungen von Hooks!


LogStarted.bat

Um den Hook in LogStarted.bat zu aktivieren, muss die Endung ".txt" aus dem Dateinamen entfernt werden!
Der Hook der Batchdatei "LogStarted.bat" wird ausgeführt, wenn eine neue Aufzeichnung begonnen wurde. Beim Aufruf werden als Argumente
die Chargennummer, die Chargenbezeichnung, die Produktbezeichnung, die Rezeptbezeichnung und die Startzeit des aktiven Logs
übergeben.


LogStopped.bat

Um den Hook in LogStopped.bat zu aktivieren, muss die Endung ".txt" aus dem Dateinamen entfernt werden!
Der Hook in der Batchdatei "LogStopped.bat" wird ausgeführt, wenn eine Aufzeichnung beendet wurde und die Logdatei in den Speicherordner
geschrieben wurde.
Beim Aufruf werden als Argumente die Chargennummer, die Chargenbezeichnung, die Produktbezeichnung, die Rezeptbezeichnung und die
Startzeit des aktiven Logs übergeben.


Automatische Protokollgenerierung nach Beendigung des Logvorgangs

Anzupassende Verzeichnispfade sind im Folgenden rot gekennzeichnet!

Zusammen mit certonVIEW ab Version 2.2 lässt sich LOGSTOPPED.BAT als Ausgangsbasis für eine automatische Protokollgenerierung im
PDF-Format nach Beendigung des Logvorgangs mit certonLOG(+) nutzen. Die nötigen Änderungen werden im Folgenden dargestellt.
1. Definieren Sie die für die Protokollgenerierung mittels certonVIEW zu verwendende Vorlage. Abgelegt wird der Dateiname in die
Variable "Reportvorlage".
REM ------Zu verwendende Reportvorlage festlegen
SET Reportvorlage= "C:\Report\Report_certonView_Vorlage_DEU.rpt"
2. Legen Sie fest, welcher Basis-Pfad zur Ausgabe von Dateien im folgenden Verlauf genutzt wird. Der Basispfad muss vorhanden sein.
3. Lesen Sie den Dateinamen in der aktuellen Log-Datenbankdatei aus. Der Dateiname wird in die Variable "Dateiname" geschrieben.
Zusätzlich werden Informationen in die Textdatei „LogLogging.txt“ geschrieben.
REM ------CLF-Dateiname auslesen
echo %~6 - Log beendet %~1 %~2 %~3 %~4 Pfad: %~7 >> LogLogging.txt
for /f "delims=" %%i in ("%~7") do set "ClfName=%%~nxi"
REM ------Endung abschneiden------------------------------------
SET Dateiname=%ClfName:~0,-4%
4. Legen Sie den Ausgabepfad für das erzeugte PDF-Protokoll auf den Basis-Pfad bezogen fest.
Falls der Ausgabepfad nicht existiert, wird dieser erzeugt. Beachten Sie dazu die Rechte.
REM ------Ausgabepfad festlegen---------------------------------
set PfadOhneDateinamen=C:\...
echo %PfadOhneDateinamen% >> LogLogging.txt
REM ------Manuelle Ergänzung des Ausgabepfads------------------
set ErgänzungUnterordner=C:\...
set AusgabepfadOhneDateinamen=%PfadOhneDateinamen%%ErgänzungUnterordner%
echo %AusgabepfadOhneDateinamen% >> LogLogging.txt
REM -------Prüfen ob Ausgabeordner existiert---------------------
if not exist %AusgabepfadOhneDateinamen% md %AusgabepfadOhneDateinamen%
REM ------Ausgabe festlegen-------------------------------------
SET Ausgabe=%AusgabepfadOhneDateinamen%\%Dateiname%.pdf
echo %Ausgabe% >> LogLogging.txt
popd
→ Der Ausgabepfad inkl. Dateiname wird in die Variable "Ausgabe" abgelegt. Zusätzlich werden Informationen in die Textdatei
„LogLogging.txt“ geschrieben.
5. Erzeugen Sie das Protokoll mit dem ReportGenerator und die Darstellung mittels PDF-Reader. Dazu können Sie den Acrobat Reader
verwenden. Der certonReportGenerator.exe ist im Installationspfad von certonVIEW abgelegt.
REM ----------------------PDF-Erstellung ausführen--------------
"C:\Program Files\certon\certonVIEW\certonReportGenerator.exe" report -t %Reportvorlage% -f pdf -i %7 -o "%Ausgabe%"
REM ------------------------------------------------------------
REM ----------------------PDF öffnen----------------------------
REM
"C:\Program Files\Adobe\Acrobat Reader DC\Reader\AcroRr32.exe"/A
"toolbar=0&statusbar=0&navpanes=0&scrollbar=0&messages=0" "%Ausgabe%"

→ Das Protokoll wird automatisch über den Hook (Batchprogrammierung) erzeugt.


FAQ und Fehlerbehebung

Für weitere Fragen zur Problembehebung wenden Sie sich an den certon-Support ! Bei falscher Konfiguration und Fehlern erhält der Benutzer mittels Fehlerfenster eine detaillierte Fehlerbeschreibung.

Im Folgenden werden typische Fehler (Fragen) inkl. Lösungen dargestellt.
Frage:
Warum bleibt die Anzeige "Verbindungsstatus Server" rot (keine Verbindung), obwohl der Verbindungstest im Konfigurationsinterface erfolgreich durchgeführt wurde?
Antwort:
Der Verbindungstatus wird mittels dem in der Logging Konfiguration festgelegten Lifecounter (In) überprüft.
Stellen Sie sicher das dieser in der LogConfig.csv von certonLOG(+) richtig konfiguriert wird und
sich der Wert mindestens alle 500 ms verändert.
Frage: | Warum kann der verwendete OPC-Server von certonLOG(+) nicht gefunden werden ?
Antwort: | 1. Überprüfen Sie die eingestellte Server-Identität beim installierten OPC-Server. 2. Verwenden Sie bei der Suche des OPC-Servers in certonLOG(+) die IP-Adresse statt Rechnername. Ist der OPC-Server auf dem gleichen Rechner wie certonLOG(+) installiert, kann „localhost“ zur Suche verwendet werden.
Frage: | Warum weicht die erstmalig vorgeschlagene URL (localhost) bei der Serverauswahl im Konfigurationsinterface von meiner eingestellten IP-Adresse ab und muss ich diese URL ändern, um den auf dem gleichen Rechner installierten OPC-Server zu finden ?
Antwort: | Wenn sich der OPC-Server auf dem gleichen Rechner (localhost) befindet muss diese vorgeschlagene IP-Adresse nicht geändert werden. Hintergrund der Anzeige ist, das mehrere IP-Adressen dem localhost zugeordnet sind (via Windowsverwaltung) und das Konfigurationsinterface die erste mögliche IP-Adresse vorschlägt. Es ist durch das Betriebssystem gewährleistet, dass die „restlichen“ IP-Adressen (localhost) ebenfalls durchsucht werden.
Frage: | Ich kann die IP-Adresse bzw. den Rechnernamen nicht aufgelösen. Welche Lösung gibt es?
Antwort: | Unter „C:\Windows\System32\drivers\etc“ die Datei „hosts“ mit dem Editor öffnen und unter den auskommentierten Zeilen eine neue Zeile mit Rechner-IP und Rechnername einfügen. Beispiel: 192.168.100.9 WIN732VMKM Diese Datei dann speichern und schließen.
Problem: | Der Softing OPC-Server kann nicht gefunden werden.
Antwort: | In der Konfiguration des Softing OPC-Servers den Namen und die URL anpassen. Servername ohne Leerzeichen und Sonderzeichen anpassen und den Namen bei „Server Endpunkt“ hinter den Port setzen. Wichtig!: IP-Adresse verwenden anstatt Rechnername oder „localhost“!
Problem:
Diverse Probleme bei der Installation von certon.
Antwort:
Wenn keine Verbindung zum Internet – Das Betriebssystem ist hinsichtlich .NET Framework nicht auf dem neuesten Stand (mindestens .NET Framework 4). Der certon Installer bringt nur die neueste .NET Frameworkversion als Offlinepaket mit. Somit muss der Nutzer vor Installationsbeginn diese Version manuell installieren. Sie befindet sich im Verzeichnis redist.
Der Nutzer hat das Firebird Treiberpaket einer vorherigen Version nicht komplett deinstalliert (Verwendungsnachfrage bei der Deinstallation) → Certon erkennt nicht die Deinstallation → Manuelle Installation von Firebird Treiber (siehe Ablage auf Benninger Server)
Problem: | Keine Verbindung von certonLOG mehr möglich, nach einem Update von der Softing DataFeed (bei verschlüsselten Betrieb).
Antwort: | Bei einem Update von einer Version <4.20: Die Zerfikatsverwaltung in der Softing DataFeed wurde verändert. Es werden zwar alle Einstellungen und Zertifikate übernommen, werden aber in den Bereich der unbekannte bzw. nicht vertrauenswürdigen Zertifikate abgelegt. Durch das Verschieben in den bekannten bzw. vertrauenswürdigen Bereich in der Zertifikatsverwaltung ist die Verbindungsaufnahme wieder möglich.
Problem: | Keine Verbindung von certonLOG mehr möglich, nach einem Update von der Softing DataFeed (bei verschlüsselten Betrieb).
Antwort: | Bei einem Update von einer Version <4.20: Die Zerfikatsverwaltung in der Softing DataFeed wurde verändert. Es werden zwar alle Einstellungen und Zertifikate übernommen, werden aber in den Bereich der unbekannte bzw. nicht vertrauenswürdigen Zertifikate abgelegt. Durch das, in der Zertifikatsverwaltung, verschieben in den bekannten bzw. vertrauenswürdigen Bereich ist die Verbindungsaufnahme wieder möglich.
Problem:
Es werden die Anweisungen der Hooks (vermeintlich) nicht ausgeführt.
Antwort:
  • •
    Die Dateien wurden nicht in die Endung .bat umbenannt.
  • •
    Die Anweisungen sind nicht ausführbar (z.B. Tippfehler) → Die .bat-Datei "manuell" ausführen, sodass man das zugehörige Windowsfenster beobachten kann. Hintergrund: Beim Ausführen via Hook wird das Fenster nach Durchlauf automatisch geschlossen
  • •
    Es sind Anweisungen verwendet, welche Adminrechte benötigen (z.B. Zugriff auf einen geschützten Pfad). Hinweis: Auch eine Ausführung von certonLOG(+) als Administrator "vererbt" löst das Problem nicht, da dieses Recht nicht von der Applikation "vererbt" werden kann.
Problem:
Beim Testen einer Verbindung zum Server oder beim Starten von certonLOG(+) passiert nichts bzw. bricht das Programm im Splashscreen direkt nach dem Laden der Zertifikate ab
Antwort:
  • •
    In der Einstellungsdatei 'settings.json' ist eine veraltete Verlinkung auf das Signierungszertifikat eingetragen.
  • •
    'settings.json' verwendet noch Einstellungen einer parallel oder vorher installierten Version von certonLOG(+).
    Als Abhilfe die aktive 'settings.json' manuell entfernen und mithilfe von certonSETTINGS neu erzeugen.
Problem:
Nach dem Logprozess wird in certonVIEW versucht die Log-Datei zu validieren. Jedoch kommt eine einzige Meldung, dass die Log-Datei "invalid" ist, weil eine Quelle nicht angegeben wurde.
Antwort:
  • •
    CertonLOG unterstützt nicht die Validierung von Dateien. Diese Funktion ist ganz allein certonLOG(+) vorenthalten.
  • •
    Wer eine Log-Datei mit certonLOG(+) erzeugt, wird daher, die oben beschriebene Fehlermeldung angezeigt bekommen.
Problem:
"certon.Settings funktioniert nicht mehr"! Nach dem Starten von certon.Settings erscheint der Splashscreen. Unmittelbar danach erscheint eine Standard Fehlermeldung von Windows, dass es zu einem Absturz kam.
Antwort:
Für den speziellen Fall certon unter Windows 10 Enterprise, in einem Administrator Benutzerkonto, liegen noch keine Lösungen vor. Alternative Lösung:
  • •
    Unter dem Verzeichnis "C:\Users\Benutzername\AppData\Local\VirtualStore" wird ein Ordner certon angelegt. Dieser Ordner entsteht, wenn beim Aufruf von certonSettings keine Adminrechte vorliegen. Damit kann certon NICHT auf den Systemordner in ProgramData zugreifen und weicht auf eine digitale Verknüpfung aus, die eben im Virtual Store abgelegt wird.
  • •
    Der Ordner im Virtual Store MUSS gelöscht werden. Anschließend startet man certon.Settings MIT Administratorrechten und legt die Einstellungen neu an.
Problem: | certonVIEW zeigt Dateien aus Netzwerkpfaden nicht an.
Antwort: | In der "firebird.conf"-Datei den Schlüssel "RemoteFileOpenAbility" = 1 setzen. Seit Version 2.2.705.18 kann der Zugriff auf Netzwerkpfade in den Einstellungen oder bei der Installation von certonVIEW aktiviert werden (Administratorrechte werden eventuell benötigt).


Lizenzierung und Support

Lizenzierung
Folgend die Kontaktmöglichkeiten zur Lizenzierung:
Homepage: https://www.certon.net/lizenzierung/
E-Mail: helpdesk.automation@benningergroup.com
Telefon: +49(0)7625/131-245
Support
Bei Fragen bzgl. der im Handbuch beschriebenen bzw. ergänzenden Produkte, wenden Sie sich bitte an Ihren Ansprechpartner der Benninger
Automation GmbH.
Bei offenen Fragen der im Handbuch beschriebenen Funktionen, die Sie hier nicht beantwortet finden, wenden Sie sich bitte an den Support der
Benninger Automation GmbH.
Folgend die Support-Kontaktmöglichkeiten:
E-Mail: helpdesk.automation@benningergroup.com


Anhänge

Folgende Anhänge sind aufgeführt:
  • •
    Lizenzbedingungen Certon
  • •
    Sprachcodes (LCID-Nummern)


Lizenzbedingungen

Ergänzende Lieferbedingungen für die Software Certon
Stand Mai 2015
1.
Vertragsgegenstand
1.1
Die Software Certon (nachfolgend als „Software“ bezeichnet) der Benninger Automation GmbH (nachfolgend als „Anbieter“ bezeichnet) umfasst verschiedene Software-Module, die der Kunde auf Lizenzbasis erwerben kann.
1.2
Die Beschaffenheit und der Leistungsumfang der Software sowie die freigegebene Einsatzumgebung ergeben sich aus der jeweiligen Bedienungsanleitung, soweit nichts anderes vereinbart ist.
1.3
Die Software wird in ausführbarer Form (als Objektprogramme) einschließlich einer Bedienungsanleitung und der Installationsanleitung geliefert. Die Bedienungsanleitung und die Installationsanleitung können dem Kunden auch elektronisch zur Verfügung gestellt werden. Soweit in der Software des Anbieters Schnittstellen zu nicht von ihm zu liefernder Software bestehen, fordert der Kunde die erforderlichen Informationen bei Bedarf und soweit vorhanden beim Anbieter an.
1.4
Die Überlassung des Quellcodes ist ausdrücklich nicht geschuldet.
1.5
Soweit nichts anderes vereinbart ist, wird die Software durch den Kunden installiert und in Betrieb genommen. Alle weiteren Leistungen des Anbieters, die auf Wunsch des Kunden erbracht werden (insbesondere Einsatzvorbereitung, Installation und Demonstration erfolgreicher Installation, Einweisung, Schulung und Beratung, Erstellung von Vorlagen), bedürfen der gesonderten Beauftragung und werden nach Aufwand vergütet. Externe Kosten sind gesondert zu erstatten.
2.
Nutzungsrechte an Software und Schutz vor unberechtigter Nutzung
2.1
Der Anbieter räumt dem Kunden mit vollständiger Bezahlung der vereinbarten Vergütung das Recht ein, die vereinbarte Software in dem im Vertrag festgelegten Umfang einzusetzen. Ist der Umfang im Vertrag nicht vereinbart, ist dies ein einfaches, nicht ausschließliches Nutzungsrecht zum Einsatz auf Dauer. Dies berechtigt den Kunden nur zum Einsatz der Software auf einem Computer durch einen einzelnen Nutzer zur gleichen Zeit. Der Computer wird durch die Geräteadresse eindeutig zugeordnet und die Lizenz nach der Installation und Freischaltung an dieses Gerät gebunden.
Das Nutzungsrecht umfasst nur den Einsatz für interne Zwecke des Kunden. Eine erweiterte Nutzung ist stets vor ihrem Beginn vertraglich zu vereinbaren. Die Vergütung richtet sich nach dem Umfang des Einsatzrechts.
2.2
Die Übertragung der Software auf einen anderen als den installierten Rechner (z.B. Ausweich- oder Nachfolgekonfiguration) ist dabei jederzeit möglich. Der Kunde muss hierzu formlos z.B. per Mail einen erneuten Freischaltcode beim Anbieter beantragen. Ziff. 2.4 bleibt unberührt.
Eine Übertragung der Nutzungsrechte auf Dritte ist nur bei vollständiger Aufgabe der Rechte des Kunden zulässig. Der Kunde ist verpflichtet, die ihn treffenden Pflichten und Nutzungsbeschränkungen dem Dritten aufzuerlegen. Dies gilt
insbesondere für die Pflichten nach Ziffer 3.5. Der Kunde wird auf Anfrage des Anbieters die Aufgabe der eigenen Nutzung schriftlich bestätigen.
2.3
Der Kunde darf Software nur kopieren, soweit dies für den vertragsgemäßen Einsatz erforderlich ist. Urheberrechtsvermerke in der Software dürfen nicht verändert oder gelöscht werden.
2.4
Der Anbieter ist berechtigt, angemessene technische Maßnahmen zum Schutz vor einer nicht vertragsgemäßen Nutzung zu treffen. Der Einsatz der Software auf einer Ausweich- oder Nachfolgekonfiguration darf dadurch nicht wesentlich beeinträchtigt werden.
2.5
Das Eigentum an überlassenen Vervielfältigungsstücken bleibt vorbehalten bis zur vollständigen Bezahlung der geschuldeten Vergütung. Soweit im Einzelfall zuvor individuell Nutzungsrechte eingeräumt werden, sind diese stets nur vorläufig und durch den Anbieter frei widerruflich eingeräumt.
2.6
Der Anbieter wird das Nutzungsrecht des Kunden widerrufen, wenn dieser nicht unerheblich gegen Einsatzbeschränkungen oder sonstige Regelungen zum Schutz vor unberechtigter Nutzung (siehe auch Ziffer 3.5) verstößt. Der Anbieter hat dem Kunden vorher eine Nachfrist zur Abhilfe zu setzen. Im Wiederholungsfall und bei besonderen Umständen, die unter Abwägung der beiderseitigen Interessen den sofortigen Widerruf rechtfertigen, kann der Anbieter den Widerruf ohne Fristsetzung aussprechen. Der Kunde hat dem Anbieter die Einstellung der Nutzung nach dem Widerruf schriftlich zu bestätigen. Der Anbieter wird dem Kunden das Einsatzrecht wieder einräumen, nachdem der Kunde schriftlich dargelegt und versichert hat, dass keinerlei Verstöße gegen das Einsatzrecht mehr vorliegen sowie vorherige Verstöße und deren Folgen beseitigt sind.
3.
Pflichten des Kunden
3.1
Der Kunde sorgt dafür, dass spätestens im Zeitpunkt der Lieferung fachkundiges Personal für die Unterstützung des Anbieters, soweit einschlägig, und den Einsatz der Software zur Verfügung steht.
3.2
Der Kunde ist dafür verantwortlich, dass die Einsatzumgebung und die Installationsvoraussetzungen auf seinen Systemen vorliegen. Der Kunde wird den Anbieter unverzüglich über Änderungen der Einsatzumgebung unterrichten. Ziffer 1.2 bleibt unberührt. Der Kunde ist für die Installation, soweit nicht abweichend vereinbart, und eine ordnungsgemäße Sicherung seiner Daten, erstmals vor Installation und sodann regelmäßig verantwortlich (siehe Ziff. 5).
3.3
Der Kunde wird den Anbieter soweit erforderlich bei der Beseitigung von Mängeln unterstützen, insbesondere auf Wunsch des Anbieters einen Datenträger mit der betreffenden Software übersenden und Arbeitsmittel zur Verfügung stellen.
3.4
Der Kunde erkennt an, dass die Software samt der Bedienungsanleitung und weiterer Unterlagen - auch in künftigen Versionen - urheberrechtlich geschützt ist. Insbesondere Quellprogramme sind Betriebsgeheimnisse des Anbieters. Der Kunde trifft zeitlich unbegrenzte Vorsorge, dass Quellprogramme ohne Zustimmung des Anbieters Dritten nicht zugänglich werden. Die Übertragung von Quellprogrammen bedarf der Einwilligung des Anbieters, die nicht gegen Treu und Glauben verweigert werden darf. Quellprogramme hat der Anbieter nur aufgrund ausdrücklicher Vereinbarung zu liefern.
3.5
Der Kunde darf nichts unternehmen, was einer unberechtigten Nutzung Vorschub leisten könnte. Insbesondere darf er nicht versuchen, die Software unberechtigt zu dekompilieren. Der Kunde wird den Anbieter unverzüglich unterrichten, wenn er Kenntnis davon hat, dass in seinem Bereich ein unberechtigter Zugriff droht oder erfolgt ist. § 69e UrhG bleibt unberührt.
4.
Mängelansprüche des Kunden
4.1
Der Anbieter gewährleistet, dass die Software bei vertragsgemäßem Einsatz den Vereinbarungen gemäß Ziffer 1.2 entspricht.
Die Verjährungsfrist für Ansprüche wegen Mängeln beginnt mit der Ablieferung oder - wenn der Anbieter installiert - mit Abschluss der Installation. Eine Erweiterung des Einsatzumfangs (Ziffer 2.1 Absatz 2) hat keinen Einfluss auf den Verlauf der Verjährung.
4.2

4.3
4.4
4.5
4.6
Für Rechtsmängel gilt ergänzend und vorrangig zu den ALB des Anbieters Folgendes:
Für Verletzungen von Rechten Dritter durch seine Leistung haftet der Anbieter nur, soweit die Leistung vertragsgemäß und insbesondere in der vertraglich vereinbarten, sonst in der vom Anbieter vorgesehenen Einsatzumgebung unverändert eingesetzt wird.
Die Verletzung von Rechten Dritter stellt nur dann einen Mangel dar, wenn diese Schutzrechte in der Bundesrepublik Deutschland bestehen.
Macht ein Dritter gegenüber dem Kunden geltend, dass eine Leistung des Anbieters seine Rechte verletzt, benachrichtigt der Kunde unverzüglich den Anbieter. Der Anbieter und ggf. dessen Vorlieferanten sind berechtigt, aber nicht verpflichtet, soweit zulässig die geltend gemachten Ansprüche auf deren Kosten abzuwehren.
Der Kunde ist nicht berechtigt, Ansprüche Dritter anzuerkennen, bevor er dem Anbieter angemessen Gelegenheit gegeben hat, die Rechte Dritter auf andere Art und Weise abzuwehren.
Werden durch eine Leistung des Anbieters Rechte Dritter verletzt, wird der Anbieter nach eigener Wahl und auf eigene Kosten
a) dem Kunden das Recht zur Nutzung der Leistung verschaffen oder
b) die Leistung rechtsverletzungsfrei gestalten oder
c) die Leistung unter Erstattung der dafür vom Kunden geleisteten Vergütung (abzüglich einer angemessenen
Nutzungsentschädigung) zurücknehmen, wenn der Anbieter keine andere Abhilfe mit angemessenem Aufwand
erzielen kann.
Die Interessen des Kunden werden dabei angemessen berücksichtigt.
Für Sachmängel geltend die ALB des Anbieters nach Maßgabe der nachfolgenden und vorrangigen Regelungen in Ziffern 4.4 - 4.6.
Der Kunde hat Mängel unverzüglich in nachvollziehbarer und detaillierter Form unter Angabe aller für die Mängelerkennung und -analyse zweckdienlichen Informationen schriftlich zu melden. Anzugeben sind die Arbeitsschritte, die zum Auftreten des Mangels geführt haben, die Erscheinungsform sowie die Aus- wirkungen des Mangels. Soweit nichts anderes vereinbart ist, werden dafür die entsprechenden Formulare und Verfahren des Anbieters verwendet.
Stehen dem Kunden Mängelansprüche zu, hat er zunächst nur das Recht auf Nacherfüllung innerhalb einer angemessenen Frist. Die Nacherfüllung beinhaltet nach Wahl des Anbieters entweder Nachbesserung oder die Lieferung einer Ersatzsoftware. Die Interessen des Kunden werden bei der Wahl angemessen berücksichtigt.
Schlägt die Nacherfüllung fehl oder ist sie aus anderen Gründen nicht durchzuführen, kann der Kunde unter den gesetzlichen Voraussetzungen die Vergütung mindern, vom Vertrag zurücktreten und/oder nach Maßgabe der ALB des Anbieters Schadens- oder Aufwendungsersatz verlangen. Der Kunde übt ein ihm zustehendes Wahlrecht bezüglich dieser Mangelansprüche innerhalb einer angemessenen Frist aus, in der Regel innerhalb von 14 Kalendertagen ab Möglichkeit der Kenntnisnahme vom Wahlrecht durch den Kunden.
5.
Haftung
Bei Verlust von Daten haftet der Anbieter nur für denjenigen Aufwand, der für die Wiederherstellung der Daten bei ordnungsgemäßer Datensicherung durch den Kunden erforderlich ist. Bei leichter Fahrlässigkeit tritt diese Haftung nur ein, wenn der Kunde vor der zum Datenverlust führenden Maßnahme eine ordnungsgemässe Datensicherung gemäß den nach Art der Daten angemessenen Sorgfaltspflichten durchgeführt hat.
6.
Geltung der ALB Benninger Automation GmbH
Ergänzend gelten die Allgemeinen Lieferbedingungen der Benninger Zell GmbH und Benninger Automation GmbH (kurz: ALB des Anbieters), Stand: Mai 2015.


Sprachcodes (LCID-Nummern)

Die LCID-Liste von Microsoft wird regelmäßig aktualisiert. Sie finden Sie auf den Seiten von Microsoft im Internet.

Zur Konfiguration der Sprachen in der CSV werden LCID-Nummern verwendet. LCID steht für "Locale ID", und meint die Zuordnung 4-stelliger
Zahlencodes zu Kulturräumen bzw. Sprachen (Lokalisierung). Der LCID-Code wird bei certonLOG(+) als Zuordnungscode für Sprachen
verwendet. 1031 steht z.B. für Deutsch, 1033 für Englisch.
Language | Country/Region | LCID
Afrikaans | South Africa | 1078
Albanian | Albania | 1052
Arabic | Algeria | 5121
Arabic | Bahrain | 15361
Arabic | Egypt | 3073
Arabic | Iraq | 2049
Arabic | Jordan | 11265
Arabic | Kuwait | 13313
Arabic | Lebanon | 12289
Arabic | Libya | 4097
Arabic | Morocco | 6145
Arabic | Oman | 8193
Arabic | Qatar | 16385
Arabic | Saudi Arabia | 1025
Arabic | Syria | 10241
Arabic | Tunisia | 7169
Arabic | U.A.E. | 14337
Arabic | Yemen | 9217
Armenian | Armenia | 1067
Azeri (Cyrillic) | Azerbaijan | 2092
Azeri (Latin) | Azerbaijan | 1068
Basque | Spain | 1069
Belarusian | Belarus | 1059
Bulgarian | Bulgaria | 1026
Catalan | Spain | 1027
Chinese | Hong Kong S.A.R. | 3076
Chinese | Macau S.A.R. | 5124
Chinese (Default Chinese Simplified ID) | People's Republic of China | 2052
Chinese | Singapore | 4100
Chinese | Taiwan | 1028
Croatian | Croatia | 1050
Czech | Czech Republic | 1029
Danish | Denmark | 1030
Divehi | Maldives | 1125
Dutch | Belgium | 2067
Dutch | Netherlands | 1043
English | Australia | 3081
English | Belize | 10249
English | Canada | 4105
English | Caribbean | 9225
English | Ireland | 6153
English | Jamaica | 8201
English | New Zealand | 5129
English | Republic of the Philippines | 13321
English | South Africa | 7177
English | Trinidad and Tobago | 11273
English | United Kingdom | 2057
English (Default English Locale ID) | United States | 1033
English | Zimbabwe | 12297
Estonian | Estonia | 1061
Faroese | Faeroe Islands | 1080
Farsi | Iran | 1065
Finnish | Finland | 1035
French | Belgium | 2060
French | Canada | 3084
French (Default French Locale ID) | France | 1036
French | Luxembourg | 5132
French | Principality of Monaco | 6156
French | Switzerland | 4108
FYRO Macedonian | Former Yugoslav Republic of Macedonia | 1071
Galician | Spain | 1110
Georgian | Georgia | 1079
German | Austria | 3079
German (Default German Locale ID) | Germany | 1031
German | Liechtenstein | 5127
German | Luxembourg | 4103
German | Switzerland | 2055
Greek | Greece | 1032
Gujarati | India | 1095
Hebrew | Israel | 1037
Hindi | India | 1081
Hungarian | Hungary | 1038
Icelandic | Iceland | 1039
Indonesian | Indonesia | 1057
Italian (Default Italian Locale ID) | Italy | 1040
Italian | Switzerland | 2064
Japanese | Japan | 1041
Kannada | India | 1099
Kazakh | Kazakhstan | 1087
Konkani | India | 1111
Korean | Korea | 1042
Kyrgyz | Kyrgyzstan | 1088
Latvian | Latvia | 1062
Lithuanian | Lithuania | 1063
Malay | Brunei Darussalam | 2110
Malay | Malaysia | 1086
Marathi | India | 1102
Mongolian | Mongolia | 1104
Norwegian (Bokmål) | Norway | 1044
Norwegian (Nynorsk) | Norway | 2068
Polish | Poland | 1045
Portuguese | Brazil | 1046
Portuguese | Portugal | 2070
Punjabi | India | 1094
Romanian | Romania | 1048
Russian | Russia | 1049
Sanskrit | India | 1103
Serbian (Cyrillic) | Serbia and Montenegro | 3098
Serbian (Latin) | Serbia and Montenegro | 2074
Slovak | Slovakia | 1051
Slovenian | Slovenia | 1060
Spanish | Argentina | 11274
Spanish | Bolivia | 16394
Spanish | Chile | 13322
Spanish | Colombia | 9226
Spanish | Costa Rica | 5130
Spanish | Dominican Republic | 7178
Spanish | Ecuador | 12298
Spanish | El Salvador | 17418
Spanish | Guatemala | 4106
Spanish | Honduras | 18442
Spanish | Mexico | 2058
Spanish | Nicaragua | 19466
Spanish | Panama | 6154
Spanish | Paraguay | 15370
Spanish | Peru | 10250
Spanish | Puerto Rico | 20490
Spanish | Spain | 1034
Spanish | Uruguay | 14346
Spanish | Venezuela | 8202
Spanish - Modern Sort (Default Spanish Locale ID) | Spain | 3082
Swahili | Kenya | 1089
Swedish | Finland | 2077
Swedish | Sweden | 1053
Syriac | Syria | 1114
Tamil | India | 1097
Tatar | Tatarstan | 1092
Telugu | India | 1098
Thai | Thailand | 1054
Turkish | Turkey | 1055
Ukrainian | Ukraine | 1058
Urdu | Islamic Republic of Pakistan | 1056
Uzbek (Cyrillic) | Uzbekistan | 2115
Uzbek (Latin) | Uzbekistan | 1091
Vietnamese | Viet Nam | 1066
Welsh | United Kingdom | 1106